No pressure after filter change

I just installed new filters on A305.  however, there is now little pressure--only a drip comes out of faucet.  I looked at tank to see if there way to add air pressure and I do not see any place to do that.  help, please.

10replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Scott, I just sent an email to you about this. There is no pressure tank on the A305 system. If your cold water valve is fully open, then the most likely issue is the #2 cartridge. This cartridge is directional and if not installed in the correct direction, there will be now flow. Also, this cartridge can also be too packed with media, so taking it out and tapping it on its side several times will help loosen the media. Then turn on the faucet and let it sit. This should fix that issue. 

    Reply Like
  • Alma 

    Hi Im currently having the  same problem 

    Reply Like
  • Josh Harvey I just left a VM for you. Most of the customers who had this issue have resolved it by not over-tightening the housing. They all have also tapped its side, then put back. When you tighten the housing back on, please do hand tight and then 1/4 turn with the wrench. Let me know if this doesn't fix the flow.

    Reply Like
  • Alma 

    So far thats not working

    Reply Like
  • Josh Harvey Try not using the wrench at all, just hand-tightening. 

    Reply Like
  • Alma 

    done that already

    Reply Like
  • Alma 

    Now  no water is coming out at all

    Reply Like
  • Alma 

    It seems to be working now Thanks

    Reply Like
  • Josh Harvey Ok great. So what do you think fixed it?

    Reply Like
  • Alma 

    Loosening it more

    Reply Like
Like Follow
  • 2 wk agoLast active
  • 10Replies
  • 43Views
  • 3 Following